Qt製WebブラウザーFalkonのインストール

GUIライブラリーのQtで作られたWebブラウザーであるFalkonをインストールする。

Qtでの開発の参考にしようと思ったのがインストールのきっかけだった。

Qt 勉強会 @ Tokyo #64 参加報告 | Qt製WebブラウザーFalkonのソースコード調査

インストール手順

インストール情報
項目 説明
配布元 Falkon
リポジトリー

手順 README.md – falkon.git – Cross-platform Qt Web Browser
依存情報 CMakeLists.txt – falkon.git – Cross-platform Qt Web Browser
依存先 (必須)
  • CMake, ECM 5.27.0+, OpenSSL
  • Qt5: Core, Widgets, Network, Sqk, QuickWidgets, PrintSupport, WebEngine, WebEngineWidgets, WebChannel
  • UNIX系OS: XCB, xcb-util
依存先 (任意)
  • KF5Wallet 5.54.0+, KF5KIO 5.54.0+, KF5Crash 5.54.0+, KF5CoreAddons 5.54.0+, KF5Purpose 5.54.0+
  • PySide2 2.0.0+, Shiboken2 2.0.0+, ICU (LibIntl)
依存元
インストール手順
sh -eux <<-"EOT"
PKG=falkon VER=3.1.0 TAG=v$VER
LOCAL=~/.local J=$(grep -cs '^processor' /proc/cpuinfo || echo 2)
mkdir -p "$LOCAL/src"
cd "$LOCAL/src"

if command -v git >/dev/null; then
[ -e $PKG ] || git clone --depth 1 git://anongit.kde.org/$PKG.git
cd $PKG
git fetch --depth 1 origin tag $TAG
git checkout -f $TAG git clean -dfX
[ -e .gitmodules ] && git submodule foreach --recursive git clean -dfX [ -e configure.ac ] && autoreconf -is
else
[ -e $PKG-$VER ] || wget -O $PKG-$VER.tar.gz https://github.com/KDE/$PKG/archive/$TAG.tar.gz
tar -xf $PKG-$VER.*
cd $PKG-$VER
make -kj $J distclean clean || :
fi

cmake -D CMAKE_INSTALL_PREFIX="$LOCAL/stow/$PKG-$VER" .
make -j $J
make -j $J test
make -j $J install

cd "$LOCAL/stow"
echo $PKG-[0-9]* | xargs -n 1 stow --ignore=dir -D stow --ignore=dir $PKG-$VER
EOT
インストール成功例
日付 バージョン OS 依存関係
2018-10-20 3.0.1 Ubuntu 16.04 GNU Make 4.2.1, GCC 8.1.0
2019-06-29 3.1.0 Ubuntu 18.04 GNU Make 4.2.1, GCC 7.4.0

falkonコマンドでFalkonを起動すると以下の画面が表示される。

Falkonの起動画面

make testエラー

falkon 3.1.0でmake testを実行すると以下のテストが失敗した。

      Start  7: falkon-webviewtest
 7/12 Test  #7: falkon-webviewtest ............................***Failed   17.62 sec
...
The following tests FAILED: 7 - falkon-webviewtest (Failed) Errors while running CTest

しかし,動作検証用に使いたいだけなので,エラーへの対応は断念した。

今後の調査で原因がわかり次第情報を追記する。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です